Vassal with Java from flashdrive?

Hello… is it possible to run Vassal and Java from a flashdrive?

I’d like to be able to use Vassal on computers (other than my own) which don’t have Java installed.

Any advice on whether this is feasible, or does anyone do this already?

Thanks -
Jamie Shanks

You’re going to have to install Java on the target computer at a minimum.

That being said, can anyone tell me if Java is installed by default on Windows computers?

  • M.

On 01/04/2008, Shabba < (> wrote:

Post generated using Mail2Forum (

I can tell you …

Nowadays, Java is installed on Windows Systems…

If not : and take 5 minutes to do so …

  1. You only need to have Java installed on the target computer. (Windows Media, XP Professionnal, XP Family…)

  2. I’m currently using Vassal installed on an USB Key … here the last manual install zip :

It’s only 9 Mo !! 8)

Unzip on the key and lauch vassal.bat for Window users directly from the USB Key (or for Linux or MacOS)

  1. PLAY !!!

Thus spake “Michael Kiefte”:

No, it should be possible to install Java on a flashdrive.


Messages mailing list …

Post generated using Mail2Forum (

How is this done? I’ve tried a couple of times to install Java directly from the Sun website to the flashdrive, but this doesn’t seem to work. I found a tutorial at but haven’t tried that procedure yet.


Thus spake “Shabba”:

The instructions there look plausible, but they’re telling you how
to install the JDK (Java Development Kit) to your flash drive,
not the JRE (Java Runtime Environment), which is what you need for
running VASSAL. The JDK contains a JRE, so this would work for
you just fine, but it’s a much larger install than you need if all
you’re planning to do is run VASSAL. (If you also want to write
code, you’d need the JDK.)

What you’d most likely want to do is follow those instructions,
but download the JRE instead of the JDK.


Messages mailing list …

Post generated using Mail2Forum (

On Apr 1, 2008, at 7:26 AM, Michael Kiefte wrote:


There’s been a bit of a feud between Microsoft and Sun over Java…
Macs have Java installed by default.

Messages mailing list …

Post generated using Mail2Forum (

you can run kinda embedded linux from your flashdrive ontop of any os. this works out for win linux and osx currently, and propably some others i havent tested yet.

i am using this on my t.sonic mp3 player to work on the public mashines at my university. works like a virtual mashine thats entirely on your flash drive. although i think performance will be quite bad if you play modules with a lot of gfx

I tried installing just the JRE, but it automatically installed directly to the desktop and not the flashdrive - there was no option to choose the install path. I tried the JDK and it did let me install to the flashdrive.

I had difficulty entering the code via the command prompt as directed by the last few steps at the link I provided (it wouldn’t recognize the “notepad.js.bat” command or whatever, so I entered just “notepad” and ended up just saving a notepad file to the flashdrive) so I doubt this will work. I’ll test it tomorrow on a desktop without Java.

I think Vassal is excellent, but if this doesn’t work, in my opinion it would unfortunately be a fairly big strike against Vassal in terms of its versatility… although the fault would really lie more with Java.

Thus spake “Shabba”:

If this doesn’t work, then the problem is with the instructions or
your execution of them. I know you can run a JRE from a flash drive.
We used to bundle a JRE along with VASSAL, and that worked regardless
of where you put it.

I don’t have time at present to look into this further, but once we’ve
released 3.1.0-beta1, I’ll see about producing either (1) a bundle which
includes a JRE, or (2) instructions for making one.


Messages mailing list …

Post generated using Mail2Forum (

That sounds fantastic. Many thanks, and thanks for your help.

In the meantime I’ll keep trying with the JRE.


It WORKS !!! :laughing: :laughing: :laughing:

Well, i’m a windows User then i put here the process to install JAVA + VASSAL on a single USB key …

I’m not responsible of damages if you use this way … i’m simply an user not skilled enough on IT … but trying to help you …


  1. You must grab the JRE from a computer already installed with v1.6 at least

  2. Copy all from this directory C:\Program Files\Java[i]jre1.6.0_03[/i] from the computer to your USB KEY : k:\VassalUSB

  3. THen you have k:\VassalUSB[i]jre1.6.0_03[/i] an exact mirror of the computer source installation.

  4. Copy and unzip Vassal installation zip file into your USB Key : k:\VassalUSB\VASSAL-3.0

  5. Edit the file Vassal.bat located in k:\VassalUSB\VASSAL-3.0

  6. Type this line after REM line and before Start
    set path=.;%1%\VassalUSB\jre1.6.0_03\bin

  7. Launch now Vassal.bat directly from the USB KEY to play VASSAL

I hope it will help … :smiley:

Hey soft-bug… I tried that (modifying the command line to match my version of the JRE) and it appears to work now. Thanks for the suggestion.

Still looking forward to a bundled version with Vassal in the future… I think that would be great if it could be done.

Thanks -