Vassal won't start on windows 7

OS: Windows 7
CPU: Intel Core i7-3770
Memory: 16 GB
Video: AMD Radeon HD 6900 Series
VASSAL: 3.2.15
Java: 1.8.0_45

Every time I try to start Vassal, with or without a module, it brings up the “registry refers to a nonexistent JRE or it’s corrupted, the system can’t find the path specified” error pop-up.

I am stumped. I’ve tried uninstalling java, clearing the registry both with ccleaner and manually, uninstalling and reinstalling vassal, uninstalling both, clearing the registry again, and then reinstalling again, restarting my computer several times, etc. I’ve even deleted the appdata vassal folder just in case. Losing all of my saved tiles.

It still doesn’t launch after all that and keeps giving me the error, even though I’m able to use java normally, so I know the installation is not corrupted.

Is there a way I could just point vassal to where my JRE is located? That would make things so much easier.

No error log is being generated, and vassal is not recreating it’s folder in appdata, which I find extremely weird.

I cannot believe how easily fixed this was. On top of downloading the latest version of java, I forgot to download the SE runtime environment. I installed that and everything works perfectly now. You can close this thread, I’m just posting this in case someone has my same problem.