VQ log file

Hi all,

Been having a strange problem with this module lately. I will get a log file from another player (.vlog) and will start VQ module using wizard, selecting the saved file from my desktop. VQ will open just fine, and will look correct as far as where all the pieces are, etc.

I will then begin a log file. Immediately, Vassal will ask for a file name to be saved! This doesn’t appear to be correct (at least not according to the Vassal User’s Guide), and is not intuitive (and not how it worked last month for me). When I finish entering a name and clicking on ‘save’, the program shows in the comments that a log file was started (as usual).

I finish my move, and end the log file. No screen appears asking to save it to a file (again, opposite of what the User Guide says should happen), but the comments note that the log file was stopped (“log file written”).

I then close the module and go to look for the new log file I created, and there is nothing on the desktop that corresponds to the name I used and saved. File was not saved (as one would expect, since no screen to do so appeared after the log file was stopped).

It all seems exactly backward. I tried reinstalling Vassal with no luck. Will try reinstalling the module, but there have not been any changes to it since last install, so I fear this won’t work, either.

Any suggestions? I’m holding up the game, and we’re all tired of the delay and the problem.



Here’s the requested info:

-Model: Dell Dimension 3000 (yeah, it’s that old!)

  • Operating System: XP, Service Pack 3 (5.1.2600)
  • CPU: Celeron 2.4Ghz
  • Memory: 1 G
  • Video Card: Intel Extreme Graphics 2 (?? Not sure what the card is, couldn’t find info under Control Panel…)
  • Vassal version: 3.2.8
  • Java version: V7, update 25 (build 1.7.0_25-b17)
  • Vassal module: Virgin Queen 2.1

Reinstalling VASSAL and re-downloading the module will do nothing for you. This sounds like a procedural error to me.

When you load a logfile (*.vlog) received from someone else, the first thing you should do after loading it is play it back to completion. I don’t see any mention of playback in your post.

After you finish playing back a log all the way to completion, then you should choose to begin a new logfile to record your play. It is entirely normal and expected that VASSAL will now prompt you to choose a location and a name for this file you are about to create. Make 100% sure when responding to this prompt that you note the location where it’s being saved. It may not be the Desktop–the default location it offers you may vary depending on your preferences.

What you describe about no prompt when finishing the logfile is, again, expected and entirely normal. This is the way VASSAL has always worked. It also matches perfectly the description in the User’s Guide as I am looking at it right now (page 14 of the PDF, my bold added for emphasis):

Ah, I see that you must have been referring to the steps in the Starting an email game section on the preceding page (page 13). In that case you are correct, the steps are out of order–VASSAL will prompt for a filename and save location immediately when you Begin a logfile, not at the end as these steps suggest.

That error aside, this isn’t the right section to refer to, since you are not starting a new game, but rather reviewing an opponent’s log from an ongoing game. The steps in that section (copied in my previous post) are correct.

Feel free to contact me directly, since you are using my module (although the problem you’re having is a general VASSAL procedure error, nothing module-specific). My email is in the module help file (Help menu → How to Use This Module).