Weird Behaviour of Refresh Counters

When I run Refresh Counters, it does something strange to a series of counters. See attached pics. But if I deselect the Use Layer names to match modified Layer traits option, the screen image remains as it should. Note that there have been no changes made to the counter between dropping it on the map and running refresh counters. Normally I just accept whatever options the refresh counters has pre-populated. I do note that this has changed. Used to be only the delete pieces without a map option selected, now it has those additional 3 selected (the 2 x Use Layers and Use Rotator)
Advice appreciated.


I’m guessing image layer 1 is blank ?

As far as I recall, the only change to refreshing of layers was that option to use Layer names became the default whereas before you had to opt-in. Nothing affecting refreshing of layers once one or other option is chosen. It would be worth searching “refresh” in the 3.7 release notes to see if there’s anything else.

“levels follow expression value” is recalculating the layer afresh each time the display updates, so for that to be affected by refresh is a puzzle to me.

I might have suggested possibly an issue with refreshing the Dynamic Property (?) multtf7, but you’ve ruled that out with “if I deselect the Use Layer names to match modified Layer traits option, the screen image remains as it should”.

If you select the piece and issue this console command (from the chat window) what result is displayed?
/property select show multtf7

If that doesn’t work, you’ll have to add a text label to the piece to display the info.

As usual, if you can distil this issue into a cut-down demo module, if will help getting a fix.

multtf7 is (currently) a GP that is set by another counter. But your input has made me rethink that approach. So I added a DP to the counter and changed the property to use for layer expressions so that there was no potential conflict with the GP. Essentially a ‘stand alone’ counter now.
Refresh still gives the same result (on a new counter taken from the bin). Further the DP does not ‘fire’, either by right click select or the hotkey. The other hotkeys work though.
Mayhap there is something really, badly, wrong with the counter? Although for the life of me I have not a clue what that might be.
PS The 2nd Layer Trait seems to be the problem, that and the way the GP was set (how is that user selectable from a list sometimes is happy with no " enclosing the text but sometimes does require the "?) and adding a Layer Name to each of the Layers. BTW both Layers used the same Set Level Expression.
After doing all that, the problem has gone away.
So now I’m using a DP for each of the counters and thus the GPs can be gone.