Area of Effect shading vanishes in map viewport


I’m seeing an odd effect in Area of Effect map shading, where when a game piece with AoE shading turned on leaves the main map view, the shading is no longer visible, even if some of the viewable hexes are in the AoE radius of that piece. However, for a piece that’s in an At-Start stack on the main map, the shading persists even when it goes out of the view port.

In the images below (shade1.jpg and shade2.jpg - you may have to scroll a bit in each of them), the WW2 game in my module (TiTE - Thunder In the East) uses Supply sources, such as certain cities or Headquarters units. The supply range is an umbrella coverage effect, which I chose to depict in the module with the Area of Effect property to shade the map blue in the source’s supply radius.


In the shade1.jpg attachment, Minsk is an on-map supply center with a 6-hex supply radius. I created a transparent unmovable counter, shown selected in the pic, from which the user can turn on the supply-range shading via right-click menu or hotkey. I gave the same exact behavior to the Soviet West HQ piece shown to the east of Minsk. In shade1.jpg you can see their somewhat overlapping shaded areas. Note that the city Chernigov (scroll down to lower right) is in the 6-hex supply umbrella of the HQ.

However, if you scroll south such that the two pieces are just out of the viewport [in this case, they are a hex row north of the viewing area], the shading from the HQ disappears entirely (note Chernigov is no longer shaded), but the shading emitted from Minsk persists.


Odd thing is that the Area of Effect property is captured in a Game Piece Prototype called Supply6 which both pieces invoke. What I would like to do if possible is have the shading persist for the HQ as it does for transparent-counter in Minsk.

Besides the Minsk counter being in an on-map At-Start stack (and the HQ is originally from an At-Start stack from another window - the Soviet Force Pool), it does occupy a lower layer than the HQ. Not that it should make a difference.

Any direction on where I should be looking is appreciated.


Problem solved.

The shading persists when the source unit is out-of-viewport, if it has the Does Not Stack property.

Thought I’d post this in case anyone else had a similar problem with grid shading.