At-Start Stack and Deck-Card problem

I’ve created a module, which utilises both At-Start Stack and a Deck of Cards. Both of which are visible to all users playing online in their initial positions.

However whenever a player draws a card and places it onto the playing board (map) or moves the At-Start Stack, the other players can’t see that the item has been moved, or placed on the playing board. Why is this, and how do I rectify it so that ALL the players can see what has been done?

This seems to be a major problem, as it means the game is unplayable.

Whilst I’m asking about Decks, I have another question. Is it possible to add a right-click menu option to a Deck?

Thanks for your help.

Does anyone have a clue why this is happening?
Have I missed something, and made a key mistake?
Is it because one of the people who logged on was running an old version of the nodule (although wouldn’t that mean that at least two of the other players should be able to see each others moves)?

Could be a bug. Almost any problem that occurs online can also be seen in a logfile, so see if you can reproduce it with a logfile: start a game, start a logfile, draw a card from the deck, save the log. Then load the log and see if you can see the card being drawn from the deck. If you can reproduce it this way, send the logfile and a link to the module to me and I’ll see if I can find the bug.


Post generated using Mail2Forum (

Then change your password so that you appear to Vassal to be a different player then…

Messages mailing list …

Post generated using Mail2Forum (

OK, I’ve done as suggested, (including changing the name and password)and the log does show the movements of the At-Start counters, and the draw cards. Provided I step through the recorded movements. So it’s not a problem here.

Just seems to be a problem when playing online.

The movements just don’t appear to anybody except the person who moves them (although counters from the game piece pallet are visible).

Sounds like the player is not synched

Post generated using Mail2Forum (

I just created a log of an online game, where a payer on another computer did all the movements. I then ended the log, restarted the module, and played the log back. The other players movements were indicated in the chat window (as they have been all along), but nothing physically happened on the board.

It’s as if the At-Start (and Deck) are unique for each player, as each player can independently move the counters in the stack (from their start position)

seems the map view is not redrawn for some reason. what version of vassal? do all participants use the same version of the module? and do you use mask traits?

All participants are using the same mod version.
It’s Vassal V 3.0.17
Mask traits aren’t being used on the At-start-stack counters.
There is a Mask (cardback) on the deck, but the cards themselves are truned face up when they are placed on the board.

I wonder if it could have anything to do with the default board setup, which I’m using instead of one single board?

I’m going to try and create a very simple card deck, and install it on both my pcs to see what happens.

I wondered if it was a bug due to the number of boards, or maybe ue to the fact that the Definition of Player Sides isn’t used.

With that in mind, I created a very simple new module.
There is only one map, which I’ve also called Map. Off from the Map there is a deck of cards which is indicated by the title 54 Jones.
Players can drag a card onto the map, at which point it is turned over.
Players can then move, delete, or return the card to the deck.
I’ve run this as an online game, and I’m getting the same result as with my other game. Which indicates that the problem isn’t because of the number of boards shown at startup.

You can download this module here, if you want to check the code:

I’m going to try an make a second version which utilises the Definition of Player sides function, to see if this has any effect. I’ll put this .jar file up when it’s done here:

I’ve tried cardtest2.jar now, and can report the following oddities.
Note this .jar file was created in Vassal V3.0.17

I started the game on two different pcs. I logged into both pcs with two different Names and Passwords.
Both players (from now on P1 and P2) started by looking for an online game.
P1 and P2 met in the Main Room. P2 started a new room called TEST. P1 joined the room TEST.
P1 and P2 both started a NEW GAME (there was no other option but for both of them to Start a NEW GAME- should one have started it, and the other done something else to join the game???
P1 them drew a card, and red circle, and placed it on the board.
P2 could not see this happen.
P1 then drew the remaining 5 cards, placed them on the board.
P2 could not see any of these movements.
P2 then drew a card for the first time from the Deck (which player 1 has just emptied, so there shouldn’t be any cards). The card was a blue circle (so the cards aren’t in the same order- they are random)

P1 then left the game, and joined as P3.
P2 then retired from the game, but was asked if he as P3 (which is what P1 had just selected) would like to retire from the game.
How can P3 be shown as P3?

It looks like there are some quite odd bugs here, I just think it’s odd that I’m suffering from them. Isn’t anybody else?

Many thanks to Brent, who I met in the cardtest2 game.

The problem was very simple, and I seem very silly, because I simply didn’t know. The players joining the room simply needed to Syncronize with the player who started the game.

However, I hadn’t read about syncronizing anywhere.

I mentioned this to Brent, and it seems that this info is in the Quick Start, but we both found out that that seemed to be broken. the window opens, but it’s empty.

The other problem we found was that anybody who joins a room could start a new game, and it should be locked so that only one person can create the new game (the person who opens the room?). At the moment, anybody in a room can start a second (third or more) rooms.

Thanks for all your help and ideas, especially you Brent,
and remember SYNCRONIZE!