Can someone help me load this map image?

I’m trying to replace the map image in my battletech module with an updated, more accurate one that’s about 2 MB larger. Every time I try, VASSAL says I’m out of memory. I managed to shrink the image down to a 3 MB file (from 14) and VASSAL still said I was out of memory. I tried creating a new module with the updated map, and before I added any counters, VASSAL said I was out of memory. … jIW-a?dl=0 … h.png?dl=0

These are the links to the module and the image. I want to replace “mapwithborders” in the 3025 Board with the “3025mapReach” file.

Any help would be greatly appreciated, thank you.

Done - you can pull down the updated vmod at:

You may need to increase your heap size when you load it.

Let me know when you’ve pulled it down so I can remove it from my server.

Also: my god is that a big map! :smiley: You might want to add the option to zoom out further!


Thanks for the help…how big should my heap size be? I’ve put max at 2048 and vassal still seems to hang when loading.

Hunh. When I first did the edit, and then tried to do “New Game” from the module menu, I had a heap crash. At that point, I’d had it set to like 256MB I believe. So then I boosted it to 512MB. And when I launched the module the next time, it came up no problem. And I’m able to launch the editor with it no problem, too. I’m on Windows 10, and some regularish Java 8 package.

Not sure why you’re having a hang! It is, after all, not THAT big of a file. We’ve gotten beyond my technical knowledge I’m afraid – you may have to post something in the tech support forum. :frowning: