Debug help - Zone not found

I hope I am posting to the correct forum. Please advise if I am not. Assuming this is an acceptable place to post…

I need some help on my first attempt at creating a module. During run time, I test the right click action on each of two sides in a wargame, and I get the following error message:

Bad Data in Module: Cavalry (W) [Send to Location - Elim] - Zone not found Zone=West Dead Pool

Each side has a prototype (“East Units” and “West Units”), each of which has a send to location command to send the unit to their respective dead pool. The dead pool is a single map with two boardds (East Dead Pool and West Dead Pool). board has a zone defined for it (East Dead Pool and West Dead Pool).

I’m not sure why I get the error message because there is indeed a zone called West Dead Pool. I get a similar error message when attempting this for east (zone not found zone=east dead pool).

Any idea of what I should check?


CurrentBoard = ‘nameofboard’ && CurrentZone = ‘nameofzone’

Note the caps.

Hi Tim,

Thanks for the response. I can appreciate the need for all of that information. Before I do, I’m going to poke around in my module. I was sort of hoping for general suggestions as far as what might have caused that; a quick known-issue approach rather than a full debug. I suspect if it’s something I did, I can take some action within the GUI to undo it. If I get completely stuck, I’ll respond again with the technical data. Certainly one more go at it will help me learn more about Vassal module development.

All the best,

I just wanted to share what I found regarding the solution I found and my approach.

I focused on exactly what the error message said, that a zone couldn’t be found.

I simplified the problem by removing module elements until I didn’t get the error message anymore. In this case, it was removing the Send To command within each side’s prototype.

I then added back and tested in small increments, undoing my action if the error appeared again.

I tried a send to command to somewhere else; that worked fine so the problem was with the specific map and zone.
I deleted the map and zones and recreated those objects. I tweaked the names so that any old code (if any junk was laying around) couldn’t find the old code. It worked fine and I no longer get the error message, and my Elim routine works fine for all my units with the assigned prototype.

All the best,