Editing Extensions

Is there a trick to editing an extension? I go in and edit it, svae it, the new dat/time is reflected in the file info, but when I open the module it retains the original extension, not the edited one. If I go back to edit the module again, all cahnges are gone (although the file date changed). Very frustrating!

What’s in the extension? What are you not seeing in the module?

It’s a vdmx file. The extension has new units, but some are placed under the wrong headings (a German vehicle unit under Russian foot, for example). I go in to edit the extension, move the German vehicle to the proper heading, save the file, and voila! no change when I open the parent module. And when I go back to edit, no change. Yet the extension file has a new date/time.

This is exceptional weird. The parent modules appears to “remember” the contents of the vdmx file when it was first loaded. Nothing seems to change after that: I can od the extension, see the new date/time and size reflected in the extensions folder, but when I ope the module, there is no change. Even if I remove the extension, open the parent, then add the extension again, the parent still remembers the first time (I mean, don’t we all ;-)? This happens even if I rename the extension. What’s more, somehow the parent overwrites the modified extension with the original, although the data for the vdmx file doesn’t change.

It must be writing the original extension somewhere.

I think we’d need to see the extension and module to advise further.

Where do I send them?

Upload them to a form of cloud storage (Google Drive, OneDrive, Dropbox, Box, et al), then make a shareable link and post it here.


The problem is in the monster extension. Check the “German foot” category. The "Luchs: is a vehicle and the Panzerschrek should be moved.

This is not the original extension, rather it is one I tried to start from scratch, But it has the same problem.

What are the exact steps someone needs to take to replicate the problem with the files provided?

I’m having similar issues. Once I edit an extension, neither “save” nor “save as” work. In both cases, the button greys out and the application freezes. I’ve even tried creating an extension all in one go, so I wouldn’t have to make any edits that won’t save, but it freezes up mid-edit and crashes.

Add the extensions and open the parent module once.
Close the module and go to edit the Monsters extension.
Go to “German Units” and find the German Units/Foot category.
You’ll see “panzerschrek” has been misplaced. Move it up so that it is in the scrollable list.
Save the extension and close it.
Reopen the parent module. Go to German HQ/German units. The “panzerschrek” unit should now be in the “Foot” list. (Currently, it remains incorrectly displayed on the right.)

I’m not sure if this is relevant, but you have two characters transposed in the file suffix of this extension. In the OneDrive folder, it shows: Monster 2 - Copy.vdmx

You want the file suffix of extensions to be .vmdx

EDIT: This probably isn’t related to the problem. I can replicate your experience–after editing the extension to move the indicated unit into the identified scrollable list and saving, the edits are not being retained. Opening the extension again in the Editor shows the piece reverted back to its original incorrect location.

Yeah, it reverts back, but the info for the file in Explorer remains unchanged. What I can’t figure out is where the old data is stored.

Thanks for the report. There appears to be a bug in cut and paste in extensions. I was able to confirm what you found. Ctrl-X and Ctrl-V on the offending piece fails in a slightly different way, it creates the new piece properly, but leaves the old piece behind.

The work around is to Ctrl-X/Ctrl-V, save extension, reload extension, delete old entry, re-save. Painful, but it will get you going.

I have confirmed this is also a problem in the 3.7 beta. I have created an issue for this and will investigate further.


1 Like

Strangely enough, that works. Many thanks!

I have reviewed and reworked the Extension editing cut and paste code to bring it into line with the standard version. This should fix both issues discussed here.

I have created a new test build VASSAL-3.7.0-SNAPSHOT-139ce7c-12403-ExtensionCutPaste (available from www.vassalengine.org/builds). I’d appreciate it if you could give this a try and see if it resolves the issues you are seeing. Just be careful not to overwrite your current versions if you are not already using the 3.7 beta.