ERR_SSL_PROTOCOL_ERROR when downloading modules

I attempted to download a module and I’m getting the following message. The module was Air Force, but I tried a few others and still get the same message. Using comcast and diagnostics finds nothing. Have never seen this is before but my first attempt downloading after the site upgrade [which looks great btw]

The connection for this site is not secure sent an invalid response.

  • [Try running Windows Network Diagnostics](javascript:diagnoseErrors()).


@Skaith What was the exact URL you were trying to access that produced that error?

Sorry not sure, not the best at the internet at times.

I went to modules and went to the Air Force module.

Then I clicked on the Airforce BL v1.0 link to download the module.

At which the error message popped up on the screen.

Hopefully that helps?

Filename Filetype Size Date Compatibility
AirForce_BL_v1.0.vmod Module 56.3 MB 11/2018 unknown

I tried that URL just now and got no error. Hmm.

Humm… really odd, just tried it with no luck. Same error message.

I’ve downloaded modules before - same PC, same comcast so I’m stumped.

I’ll play around from my end a bit in a couple of days and see if it’s something on my end, but no idea
what that would be.

@Skaith Is this happening with all modules, or just that one?

Looks like it’s on all of them. I just tested 7 of them with the same result.

The odd part is that 4 of them are modules I had downloaded previously.

Starting to think it might be something on my end since no one else has brought it up as far as I

Not sure what it would be however as it is still the same PC/Software/Connection.

@Skaith Are there any additional details with the error message?
Can you click the link when you have a Web Developer Tools or similar open in your browser (Ctrl+Shift+I)? That would likely display a lot more information.

Okay blindly learning something new here. :slight_smile: Sorry I can do the basics but outside that I’m in trouble.

So I rebooted and then tried opening up the old internet explorer to try downloading - a different message. Can’t connect securely to this page

Can’t connect securely to this page

This might be because the site uses outdated or unsafe TLS security settings. If this keeps happening, try contacting the website’s owner.

Then back to Microsoft Edge [Windows 10] and tried the Ct/Shift/I and pulled up Microsoft Web Development tools - never knew they existed.


That one is what showed up when the error message was up

This one with the Air Force link up

Hope that helps - if you want me to pull up anything else let me know - but headed out for dinner and a meeting so I’ll have to do it tomorrow most likely in the afternoon.

Thanks for the help!!

IE is Not Supported Anymore. Seriously. I don’t care what problems anyone is having with IE. :slight_smile:

What you posted there is not what I was asking for, but in the neighborhood of it.

Here’s what I see in Firefox:

Do you see the bottom half of that window, where the yellow bars are? That’s showing HTTP requests being made and their results. If I open the Web Developer Tools window and click a link, that part of the window will show the request made due to my click and the result of the request. So if you have this open when you click that link, it should tell you more about the problem.

Hum… thinking this “might” be it?


Those are exactly the requests I was hoping you’d find. Is there any more detail there, say something you can expand or right-click on? There should be a way to see the raw request and response.

There is a lot of information under an Elements tab.

But not seeing anything that looks like a request and response - of course I might not recognize it.

I’ll try and play with it again tomorrow and see what else I can pull out of it.

Have to run or my wife is going to kill me for making use late.

I, too, am having this error on whatever modules I attempt to download. I put a thread in the Technical Support and Bugs that echoes this one.

Okay I think I found the information you are looking for, lots of screen shots though since I am not sure what you need and it seems like there was a lot of information. Also kind of glad I’m not the only one

not the only one.

I’ve set PHP not to produce X-Powered-By headers anymore, which showed up in the screenshots above, but that’s not relevant for the problem.

Wow, that linter is quite opinionated. Some of those recommendations are strange.

@Skaith @JaySixA With what browsers does this happen for you? I have yet to be able to replicate the problem.

Microsoft Edge for me.