Game Piece Palette Freeze

I’m running Vassal 2.9.9 on a Mac. The application freezes whenever I try to add a second Game Piece Palette to a module.

Is this a bug, or is there some preparation necessary before adding a second palette?

On Mar 6, 2009, at 8:28 AM, Kim wrote:

Seems to work for me.

How are you running/starting Vassal?

I just downloaded the 2.9 version from the archived Web and started it
with the shell script.
What are you running with?

Do you know how much memory is allocated to Vassal?

Messages mailing list …

Post generated using Mail2Forum (

I run it by clicking the application’s icon in the Dock. The version I use was downloaded from

Haven’t a clue. How do I determine that?

What I did just try was having a look at one of the modules on the Vassal website which does use more than one Game Piece Palette. Battlelore was the one.

I stripped everything from that bar the two palettes, and re-added the other necessary elements. That worked, allowing two Game Piece Pallettes. The only thing which seemed odd was that it took quite a while to save each step. Usually, saving between adding elements is fast.

Yet, when I again tried building a new module from scatch, it froze as soon as I tried adding a second palette.

On Mar 6, 2009, at 10:04 AM, Kim wrote:

I just downloaded that version and it seemed to run fine.

Can you tell us a bit more about your system?
What kind of Mac, which version of the operating system?

When I try it on my machine, I’m able to create a simple little module
with multiple palettes and a simple board. I didn’t get very far in
trying to create actual pieces, but adding multiple palettes didn’t
cause any problems.

Messages mailing list …

Post generated using Mail2Forum (

It’s an eMac 800 MHz PowerPC G4, with 640 MB SDRAM.

Were you able to name any of those palettes?

Which operating system version?
And if you know it, which java version?

I didn’t add any counters to the palettes, but they do have names.

See the module attached here.

Kim wrote:

Eep. I’d forgotten that was still there. If you have a new enough
version of OS X and Java, you can download the newest version direct
from the VASSAL web-site - the site is now

I’ve updated the wiki and left a README in the archive to make sure Mac
users aren’t using an old version unnecessarily. I’ll leave the archive
up, though, to help with users stuck at Java 1.4.


Messages mailing list …

Post generated using Mail2Forum (

Panther 10.3.9
Java is 1.4.2_12, which is the latest version Apple has available for Panther.

Sadly, Vassal gives me an error message when I try to open your module.

Sadly, I’m stuck with Java 1.4.2_12 at the moment.

On Mar 6, 2009, at 3:40 PM, Kim wrote:

Post generated using Mail2Forum (

Sorry to out you to this trouble.

Thanks for the advice, but it really isn’t an option just now.

Yes. I tried various methods of opening it. but Vassal responds with either Not a VASSAL module or Error in opening zip file.

Thus spake Thomas Russ:

I’ve added .vmod, .vsav, and .vlog as allowable file types on the the
new forum, so once we switch, it will be possible to upload those.


Messages mailing list …

Post generated using Mail2Forum (

Sorry, realised where I was going wrong with opening your test module. I’ve now opened it in Vassal in Edit mode.

I can see your multiple palettes. And I can edit them. But Vassal freezes, just as before, if I try to add another palette to your module.

Puzzling, isn’t it?

Just realised you’ve solved the immediate problem by posting that test module. As I appear to be able to modify it, I can simply use that as the base module from which to build. Thank you.

Thus spake Tim Franklin:

Tim, would you mind if I grab those and add them to the release archive?


Messages mailing list …

Post generated using Mail2Forum (