graphics stretch in linux

tried to run Vassal under xubuntu… the graphics came out a bit of a mess as the text label locations are quite different from those under windows. generally there were a few buttons that were vertically padded and the text locations seems to have xtra vertical padding from their respective anchors.

see attacked png

versus here is how it looks in windows

hmmm…

same module, same beta, using the default map screenshot, but the one posted from xubuntu linux came to the forum from firefox and the one from windows thru ie7.

odd that even the map sizes do not show up the same - one produces a larger png image anyhow

aha - I must have one zoomed when I hit the screen dump button in vassal. odd that it takes the current zoom level into consideration though?

anyway that is not related to the issue of being vertically displaced / horizontally stretched.

This is probably no more than a difference in font sizes between the two machines. You might do better making the numbers top-justified, rather than trying to set the position of the bottom of the text directly. The only guaranteed way of making the numbers consistent across systems is to use bit-mapped images for the digits and use them in a Layer.

rk

Post generated using Mail2Forum (mail2forum.com)

Thus spake “IrishBouzouki”:

This might be a bug, not a font problem. I’ll look into it.

That’s the intended behavior.


J.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

Thus spake “IrishBouzouki”:

Where can I get a current copy of this module?


J.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

http://www.user.shentel.net/pmurphy/Strategos/Strategos.vmod
is this perhaps something to do with using xfce on a widescreen laptop?

oddly, or perhaps not, this bug is now gone with my new loadup (same module).
had the bug under whatever random jre the openjdk in synaptic loaded, do not have the bug with the sun jdk 6u10 for amd64.

well, I should be precise, the module is slightly changed, but not in any aspect that should affect the graphic prsentation of the pieces. I think the only new thing was I changed one of the html files for the charts.

okay I can definately confirm this is an issue in openjdk 64-bit under 64-bit linux with a xfce desktop (version… hang on… 4.4.2)
it worked with sun jdk 1.6.10 64-bit but fails in this way with openjdk 64-bit, both originally and again now.
the failure happened both times with packages loaded by the xubuntu package manager, but not with the sun version downloaded and installed from the bin (when sun was the only java on the system).
when it is broken the buttons on the menus are all mis-shapen and stretched vertically and the locations of the text are offset while the pieces are stretched horizontally.
oh… beta5

now… anyone know of a good way to force vassal to look for the sun jdk on my system instead of openjdk? is it done using one of the java policy tools or is that something completely unrelated?

is there a file somewhere with the java path info that I can edit and flip the locations of sun and open versions? (yes, they should be the same, but it seems at this point they are not in some small buggy detail)

but have no fear… those two policy tool apps… the openjdk one is stretched vertically, the sun one is not… so this is not unique to vassal by any means… but it would be nice if you happen to know a work around to tweak which java gets picked for an app (or vassal in particular)

finally, not sure if this is from the error or something else, but noticed these lines in my xsession error log…

/usr/lib/thunar/thunar-vfs-pixbuf-thumbnailer-1: Unrecognized image file format.
/usr/lib/python2.5/site-packages/LanguageSelector/gtk/GtkLanguageSelector.py:740: GtkWarning: gtk_cell_view_set_cell_data: assertion `cell_view->priv->displayed_row != NULL’ failed
cell = combo.get_child().get_cell_renderers()[0]
catfish.py:322: GtkWarning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
widgets = gtk.glade.XML(filename)

figured out how to target it, have to type the full path to the jre bin/java file as part of the java call in the sh script AND have to type the path back to the vassal launcher from that jre.
and by doing that confirmed yet again that the sun jre works fine with this setup but the openjdk jre does seem to have this graphics issue.

Thus spake “IrishBouzouki”:

Which version of OpenJDK? Are you sure that what you have is current?

I’d like to see screenshots of this.


J.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

It is the most up to date version of openjdk from the xubuntu repository as of late last night (nov-26), with an apt clean and update to make sure. I was pretty *nal about it, checking it against the version on the website, because the whole out of date repositories thing is really bugging me. It was version 6, the particulars are numbered differently from the sun updates but let me grab them off the other machine and I will post them here.

okay Joel I will work on getting that up shortly.

john-murphy@john-murphy-laptop:~$ java -version
java version “1.6.0_0”
IcedTea6 1.3.1 (6b12-0ubuntu6) Runtime Environment (build 1.6.0_0-b12)
OpenJDK 64-Bit Server VM (build 1.6.0_0-b12, mixed mode)

(that is the openjdk version, which made itself the default on my machine)

alright I will show my lack of linux coolness here… how do you do a print screen in xfce?
I will search to find out but meanwhile might be quicker if you know if you would let me know how.

this is the module launcher screen with open jdk and with sun jdk

Thus spake “IrishBouzouki”:

I have no idea about what facilities xfce itself provides. If I want to
capture the full screen in GNOME, I can hit the Print Screen key, but
most of the time what I want to capture is a single window. For that, I
would start the GIMP and go go File > Acquire > Screenshot.


J.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

IrishBouzouki wrote:

If you’ve installed both through the package manager,
‘update-java-alternatives’ will let you toggle between them.

‘update-java-alternatives -l’ to list the JVMs you’ve got available on
the system, then 'update-java-alternatives -s ’ to set the
system to use a particular VM.

I’m afraid I don’t know a comparable GUI way of doing things.

Regards,
Tim.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

I would guess I should be able to make a couple .sh scripts I can click on to execute instead of opening a terminal… but I am also happy for now just with having the vassal.sh script edited to use the sun jdk to avoid this one problem.

however… knowing how to change VM’s is a handy tool to have at my disposal.

Thanks Tim.