How to edit existing map that has hexes but no hex numbers

I’m interested in War in the East and eagerly downloaded the files for it. The map is beautiful but has no hex numbers. Is there a way to edit this programmatically? I’m a retired software engineer and have the original boxed game.

Thanks for any advice.

Gerry Murphy

Forgive my crude drawing (I did it with a touchpad, not a mouse)–you could use the VASSAL Editor’s tools to draw a Zone corresponding to the area outlined in red, then inside that zone create a hex grid. Lastly, design a grid numbering scheme.

Ah, thanks so much. I’ve looked for that info without success and may not have found it otherwise.

Do I need that middle step since the game module already has a hex grid?

I’ll give it a try and let you know how it goes.

Thanks again.

Gerry Murphy

Depends on your goals. If you are seeking to modify the map image itself to add hex numbering, that’s an image editing operation outside the scope of VASSAL. You’d use some other software to do it–Inkscape, GIMP, Photoshop, Illustrator, et al.

If you want hex numbering for purposes of playing a game in VASSAL and having it report hex locations when you do things like move/destroy units, then yes, you need to create a hex grid first and then apply a grid numbering scheme to it. This is creating a hex grid that only exists in VASSAL, it would not modify the actual map image itself, but overlay it.

I’d like the second option. So, this wasn’t done for the existing package?

If you want hex numbering to show or even just report you have to create the hex grid in VASSAL so that VASSAL knows where the hexes are.

I just took a look at the module, and it does have (multiple) Hex Grids already defined, you just need to turn on the hex numbering:

  1. Open the module for editing
  2. Open Main Map [Map Window], [Map Boards], [Board], [Multi-zoned Grid], NW Map [Zone], [Hex Grid]
  3. Double-click on [Grid Numbering]
  4. Toggle the Draw Numbering checkbox on.
  5. (Optional) Adjust the Font size, Color, etc., if you feel the need (the defaults look good to me, though).
  6. Repeat steps 3-5 for the other 3 Zones.
  7. Save the module.

Edit: This does cause VASSAL to print hex numbers in places that shouldn’t have them. To fix that, you’ll have to edit the shape of the Zone (double-click on NW Map [Zone], etc., then click on Define Shape) so it doesn’t extend beyond the actual hexes. This might cause problems with using the German Replacement Division Track, however (I didn’t delve deeply into the module)–fixing that would be significantly more complicated (as it would probably need to have its own zone defined, and then code that uses it updated to reference the new zone).

Edit 2: I also just noticed that each of the 4 zones starts numbering from 0101 (or 0201 for the southern zones, for some reason), so you have duplicated hex numbers. While this can be fixed fairly easily (from the same Grid Numbering edit box you used to turn on the numbers), that might break the module, if it’s relying on those hex numbers to place counters in the right positions (again, I didn’t investigate very thoroughly, so it might not actually matter).

1 Like