Modules disappear from module library after upgrade

This isn’t intended and certainly isn’t normal. I never have to do this.

1 Like

Yes and no.

Yes, we intend to do more, smaller releases from here on, to reduce the time elapsed from a bug being reported to when it’s fixed and to help isolate when bugs were introduced.

No, we haven’t started doing that yet.

What you’re seeing now is a release pace typical of times in the past when we’ve only been fixing bugs—a release every one or two months.

That shouldn’t happen. We can look into it if you can provide more details.

Could the reason his new version isn’t “seeing” his installed modules be because maybe he’s uninstalling the old version first?
Hipshot, you don’t need to uninstall the old version first. Instead, just install the new version and it will overwrite the old.
I’m also on desktop (Win7, with 32-bit Vassal installed) and I’m not having your problem.

This isn’t a viable explanation because a user’s list of modules is stored in personal VASSAL preferences (e.g. on Windows this location is: C:\Users\user-name-here\AppData\Roaming\VASSAL\prefs). Uninstall or subsequent install of newer versions will only affect the core software (usually C:\Program Files\VASSAL)–user preferences are never removed or modified.



We need to see the prefs file before and after the problem occurs.

Phew! I saw this and thought modules were getting wiped from our website library lol!

It’s always happened to me I just assumed it was normal. I have to find every module and re open it. I don’t know if prefs are reset

1 Like

Exactly the opposite. This should never happen.

Are you able to make it happen any time you install Vassal? If so, please let us know. We need the help of someone who can reproduce the problem in order to troubleshoot it. Without that, this problem will never be fixed.

I notice this issue frequently too. As I install multiple versions of Vassal and sometimes switch between them I’d associated the issue with non-standard use. I’ll try and provide before and after prefs next time I see it happen.

Actually hasn’t happened for a while… but of course I just installed .14 and all of my modules have vanished bar 2 in dev modules that Mark had asked me to try, no idea why these two in particular were not disappeared on me (they are in the same place as all the rest). I tried a restart etc. and nope everything gone. It is a little frustrating sadly.

If there’s anything to be learned about why this keeps periodically happening, as indicated earlier you’re going to have to make a preemptive copy of your VASSAL preferences before installing an update and then another copy after you detect modules gone missing from your library, so these files can be compared.

Assuming you’re on Windows, the file you want to make a copy of pre-install and post-disappearance is:

For MacOS:
~/Library/Application Support/VASSAL/prefs/V_Global

Reminder that in both cases these folders are hidden from the user by default, so you need to take steps to unhide them in your file manager or know how to navigate there specifically.


Thanks Joel, is the fault caused because I do or don’t remove the old version at time of install?

In theory there should be absolutely no impact from your decision to keep or remove prior versions, as none of the installation process touches your personal preferences at all.

Thanks just so you know, it happened after a reboot (not even a reinstall/update) so to be clear, I installed 3.6.17 and did NOT lose my modules, it has worked for a while, I have then rebooted my PC (it always just sleeps) and now I came to it last night and boom all modules gone. I thought maybe it is slow booting up or something so I thought I would restart again and be more patient then loaded Vassal and nope.

Here is what the folder looks like:

If modules disappear from the Module Manger, it would help us to see the errorLog from that run. There’s not much we can do without that.

2023-05-24 20:00:50,184 [22540-main] INFO VASSAL.launch.StartUp - Starting
2023-05-24 20:00:50,194 [22540-main] INFO VASSAL.launch.StartUp - OS Windows 11 10.0 amd64
2023-05-24 20:00:50,195 [22540-main] INFO VASSAL.launch.StartUp - Java version 20
2023-05-24 20:00:50,195 [22540-main] INFO VASSAL.launch.StartUp - Java home C:\Program Files\VASSAL-3.6.17\jre
2023-05-24 20:00:50,195 [22540-main] INFO VASSAL.launch.StartUp - VASSAL version 3.6.17
2023-05-24 20:00:50,265 [22540-AWT-EventQueue-0] INFO VASSAL.launch.ModuleManager - Manager

But this is after everything has disappeared and after I have reopened CCN (as it is now the only module showing). I will update to 3.6.19 and see if even that one disappears. I will copy the V_Global now.

Sadly, the CCN module has not disappeared so no changes.

There’s nothing of use in that errorLog, sorry.

I have gathered some evidence from my recent experience of this problem and raised GitHub issue #12344 for it.