Place marker only places on top of stack

I noticed an unfortunate behaviour in my module, which is that when a marker is placed on a unit counter, it is not placed “on top of this piece” as it is specified in the trait, but always goes “on top of stack”.

Incidently, it also does not match the rotation of the unit counter, even though the marker also has “Can Rotate”, and Place Marker has “Match Rotation” set.

I use Vassal 3.6.19. I doubt that this is a bug in Vassal, because it would have been discovered long ago, so what could I have done wrong?

Well, it always helps to formulate a problem in order to solve it.

I haven’t solved it yet, but I just noticed that while I have this problem with one side (British), there is no problem for the other side (German). I need to compare definitions for the two sides, and find out where I went wrong with the Germans.

Sorry to have bothered you!

OK, the problem has been solved. It was caused by some counters defined by a saved game, and others that were new. Sigh.