Quick Sanity Check

Working my way through a module (in 3.2.17), and although in many areas I’m having success, I’m encountering a few “very strange”-seeming behaviors, and wondering if I’m missing some very basic workflow step.

Here are my symptoms:
(1) There are some permanent text labels below the card deck spots, placed there as “At Start Stacks” with a nested “Single Piece” that contains the text label. But when I edit the text label, save the module out, and then load a game in the module, changes to the text label don’t appear.
(2) There are some menu items placed in as “Global Key Command” and keyed to a key command. But if I edit the “Button text” for one of the items, even a minute change like adding one letter to it, and then save the module out, that whole menu item disappears from the menu and won’t reappear until I change the “Button text” back to exactly what it was before.
(3) I have decks where the “draw outline when empty” box is checked, but the outline isn’t being drawn. Even though other decks do draw the empty box outline.

Things I have tried:

  • Refresh Counters (this works when I’ve changed actual functional prototypes, but isn’t helping me with getting basic text changes to actually display)
  • Saving the module, closing the edit session out, and reloading.

Am I missing some basic refresh-the-crap-from-the-file type of operation? (Analogous to needing to refresh counters when changing prototypes)?


So after making changes, are you testing them using a pre-defined setup? I.e., any kind of saved game file that was created at a moment that pre-dated your changes?

If so, that’s not going to work. One of the very frustrating parts of design as it relates to scenarios/saved games is that only creating a brand new game from scratch will ensure you see all the effects of changes you’ve made. The Refresh Counters tool helps to some degree, but there are many things it can’t touch–anything involving deck configurations (e.g. drawn outlines of empty decks), zones/grids/regions of a map, XY positions of pieces and at-start stacks, and quite a few others I’ve run into in the past.

Oh my, yes I see what you mean. I will probably start wishing I were dead when I have to go make the pre-defined setup all over again :slight_smile: Thanks for the sanity check though, sure enough the little thisses-and-thats started appearing correctly as soon as I dropped the load-the-scenario thing.

Or, well, ALMOST. When I got rid of the “scenario load” all the decks came back EXCEPT FOR ONE. It’s the farthest lower right one, and the very last one defined. But other than that I can’t see anything “wrong” with its definition. I tried moving it around on the screen to see if that would make it reappear but no luck.

Any thoughts on getting back my missing deck?

Okay I’m squared away - the missing one turned out to be secretly “owned” by the wrong board even though it didn’t show that way in the dialog box. Found it by looking at the buildfile with XMLSPY. Once I changed the owning board to something random and then back to “any”, everything worked after that.