Rectabgular grid not found in my zone

I tried to have a rect grid work for a senttolacation trait, but for some reason, the grid being defined under a mutlizone/zone was not found by the trait.
I had to move it up one step, as a grid for the multi zone to make it work.

Does this seem a regular behaviour to you ?
I can handle that. I just need to make the grid bigger.

I named the map and board correctly.
And didn’t even try any expression but a 4digits code for the grid cell.
I had an error message with grid not found on the map, which was solved when I moved it up.
Is there a specific syntax for the senttoloc trait to acknowledge the grid is in a zone ?

Well I know what “The Usual Problem” would be:

  1. Go to your Zone and open up its properties
  2. Check what is “Location Format” set to?
  3. If it is set to $name$ then that’s the problem.
  4. You want it to say $gridLocation$ instead.

This changes both the way locations w/in the Zone are passed in (to Send To Location) AND the way they display e.g. in reports. But basically if you have named sublocation in the zone that you want to be accessible, you want $gridLocation$.

Just checked the source and, No, SendToLocation does not support sending to named grid Locations within Zones, only grids defined at the board level.

Zones where added much later and support for them was not added to the SendToLocation grid location functionality. It would also be very inefficient if there where many zones defined on a board.

Great !
Thank you.
For once I didn’t do anything wrong (almost)