Report with Marker not working

With the default map setting, reports for items moving to/on the map work as intended, reporting the pieceName. However I do not want the pieceName to be reported, I want a custom name to be used. To do this, for each different prototype I created a Marker trait, eg cardtype = Cargo. I changed the map report from $pieceName$ to $cardtype$ - however the report now doesn’t report that variable. (IE it says “Player 2 moved from offboard to onboard” when it should say “Player 2 moved Cargo from offboard to onboard”)

I tried moving the Marker trait up and down in the list of traits for the prototype, still doesn’t work. All of the other features of the same prototype work fine.

What have I missed?


Markers are not variables …they are simply an identification tag. For example, you can send a command to all units where UnitType = Tank.

If you are trying to put a label on a piece that can be used as a variable to display in a report, use a Dynamic Property trait for the variable.

Thanks for the response. I swear I read somewhere that Marker could be used in reports. Maybe it was dated.

Anyhoo, I already tried with Dynamic Property (and just tried again) and I’m having exactly the same problem. Is there something else I could have missed?

I just tried putting the Dynamic Property trait straight onto a game piece (instead of using a prototype).

Dynamic Property
Name: testname
Value: testvalue

And still, when reporting $testname$ I get nothing. If I change it to $pieceName$ it works. Stumped. :cry:

In your map settings, you need to blank out all the auto reports except the last one. Set it to $message$

Then on your pieces you add the report trait and then you can use markers/variables anyway you wish to get the exact message you want. You just need to echo the report trait key command somehow when it is appropriate to what you are doing (for example by tying it into the last field of the map properties - “key command to apply to all units ending movement on this map” )

So does the map report just not work with custom properties then?