Text Label background transparency not saving


Tested in 3.2.17 and 3.3.3-beta1

Create a text label, set text color to white, background color to black and transparency/alpha to 20%, save text label. Re-open text label and the colors have been saved but not the transparency.

Tried with RGB/CMYK/HSV/HSL and no difference.

I’ve searched the archives and this doesn’t show up as a known limitation.

Any suggested work-arounds? Cheers! jas…

Seeing as this is the third time this bug has been reported in the last couple of weeks (and no developers have responded to any of them), I decided to finally figure how to file a bug report in Bugzilla. Here it is: vassalengine.org/tracker/sho … i?id=13307

Thought I had updated this thread - guess I didn’t. I’ve added the code for the fix into the bug report on the tracker. I just need to set up a pull request and it will be added…

added the pull request… I’ll update this thread once it get’s included

bada bing,bada boom… It’s in. See it live in 3.3.4? Or git clone now…

The didn’t make the 3.4.2 release. Is there a plan to roll this out at some point?

I think jestew’s PR got merged into “master”, which means it will appear in 3.5

The 3.4 releases are now all bugfixes. The next “feature release” will be 3.5. STAY TUNED FOR THE AWESOME!!!

Also (and relevantly!) I updated the “Roadmap” page in the wiki … vassalengine.org/wiki/Roadmap

Technically it is a bug, but I know what you meant - bugs from recently introduced features that have broken existing modules. This bug is so old that it’s not affecting anybody because it probably never worked…

Thus spake m3tan:

The didn’t make the 3.4.2 release. Is there a plan to roll this out at
some point?

I had intended for this to be merged to the release-3.4.2 branch, but
instead I merged it to master. Since it looks like we will be having
a 3.4.3, I’ll make sure this gets into 3.4.3.