To move a piece from map to 3 turns up the turn track

My objective is to send a piece off the map to three turns in advance of the present turn so that it is in the correct position to come back into the game.
Using the trait Send To Location I have selected Another Counter Selected by Properties.
The counter I wish to send it to is Game Turn which is in zone Turn Track.
When I enter Game Turn in the Properties Match Box is does not send the piece to the Game Turn piece but to another piece on the board.
When I enter Game Turn in the Expression Builder Property Match when I right click on the piece the Send To command is greyed out.
I have read the instructions at file:///C:/Program%20Files/VASSAL-3.2.17/doc/ReferenceManual/PropertyMatchExpression.htm

but do not understand them. I have tried numerous times with different combinations using your example but with no success.
I have looked a other Vassal modules but have not found a module which does what I am trying to do in order to learn from it.

Will somebody please tell me what I am doing wrong, an example would be really good, or tell me of a module which does what I am trying to do so I can see how they have done it.

Thank you.

If you have a zone called Turn Track, why not set the Send to Location to “Send to Zone”, select the map the counter is on and “Turn Track”


If you want to send it directly to the counter Game Turn, in the zone Turn Track, then enter the property filter of

CurrentMap = && CurrentZone = Turn Track && BasicName = Game Turn

The “For the People 3.2” module actually has an example of precisely this – it’s even exactly 3 turns ahead.

It’s a complex module, but to find it:
(1) Open module for edit
(2) Find and open “Game Piece Prototype Definitions”
(3) Scroll down to “CSA General Cav” (in the “=== Generals ===” section)
(4) Open up that prototype
(5) Scroll down to the “Send to Location – Turn Track” trait.
(6) Open that up and you’ll see the configuration to send the unit to a location 3 turns in the future.

If you want to execute it in the module, start a game, and way down in the lower right you’ll find both the turn track and the reinforcement generals. You want a Confederate CAVALRY general (so a grey one with a yellow stripe, JEB Stuart is the first one to come up in the turn order, he’s at the bottom of the confederate pile for turn 2). And right click on that and pick “Displaced To Turn Track” near the bottom of the menu, and Voila – he goes to the Turn 4 box.

Thank you both for your reply’s.
I have tried both but so far no success, when I right click on the Piece the command is greyed out so I am still doing something wrong.

Dr_Nostromo. I have not yet got a tick in the Expression Builder when I enter your line CurrentMap = && CurrentZone = Turn Track && BasicName = Game Turn using for my map name. I will keep working on it.

Cattlesquat. That is a heck of a module. I do get a tick in Expression Builder but the entry in the right click menu is greyed out. I must be close to success with both methods.
Once again thank you both for your replies.

Because you mention greyed out… by any chance is your piece starting in a “Game Piece Palette”? (Where you can drag an infinite amount of that piece somewhere). Those behave differently and have more limited functionality until they are dragged fully onto the map and “instantiated”.

You don’t wan’t to use with the brackets …I just used those as a way of saying “fill this in”. If the name you’ve given to your main gameboard is Board, then the line would be:

CurrentMap = Board && CurrentZone = Turn Track && BasicName = Game Turn

This is old style Vassal syntax so you don’t need to use the expression builder. If you paste the above directly into the Matching Properties box and then click the Expression Builder, you’ll get this:

((CurrentMap==“World_Map”) && (CurrentZone==BasicName)) && (BasicName==PlayerSide)

Which will accomplish exactly the same thing.

Thanks for the follow up Dr_Nostromo.
It did not change = to == or put in the " when I did cut and paste. However the example in the above module had “” and the insert had == so it then worked. Used the Advanced options to put in an offset.
I ended up with the Expression {CurrentMap == “Main Map” && CurrentZone == “Turn Track” && BasicName == “Game Turn”}
Less brackets and more “” than yours but it works.
Thanks to you both for your help.
Hope that others who wish to do this have the success I have had.