Twilight Imperium Home System glitch


I have taken the Twilight Imperium mod and stripped the expansions, added the text (since me and friends own the game). Since then we started a game and noticed the text was displaying in chat and on the back of he cards. It’s all fixed but I exported my pre-fix piece info, imported them to new version in edit mode then loaded the save and converted. All went well except the home system tiles won’t move and are on top. I never customized those nor the pieces underneath. Why would this happen and what can I do?

Thanks so much!


I don’t understand any of the exporting, importing, or converting aspects of what you’ve done, having never worked with those things. The only thing I can personally suggest is that some map tiles for games require either shift-click or alt-click in order to re-select them after they’ve been placed. So maybe try that first.

If that isn’t the problem, or if the pieces continue to drop below the tiles, then perhaps the map-level Game Piece Layers trait somehow got affected.

Hope you get it solved.

Hello rrvs,

Thank you for your comment. I did need to shift-click or ctrl+click to move the tiles originally, that worked fine in my initial version. Unfortunately the tiles won’t move now (and are on top of the pieces). This applies only to the home system tiles, and not the other board tiles.

I will look into the Game Piece Layer traits as you’ve mentioned, for these pieces, and see whether they somehow got malformed during the conversion.

I followed the guide for doing the conversion and believe it was done correctly, I am not worried about my technique (though I can detail it if need be)

Our other option may be to start a new game (and hopefully the home system tiles will be working properly) and just work towards restoring the state.

I’ll post here if I make progress either way.



Damn, that’s too bad… well, given that, I agree with you on testing your updated (w/text working properly) module with a brand new game start. Focus on those home system tiles and the pieces that go on top of 'em… set up several, move 'em around, make sure they’re working, then save the test… close out completely, then reopen using that new saved test game… then once more make sure the pieces are above the home tiles and everything’s movable after opening from the test save.

If that all works okay, and if you still have one of your initial game saves (pre-conversion), try running through the conversion/update process for it again. Then try opening that 2nd updated game save to see if the same problem with the tiles occurs.

Good luck!


I’ve had more time to play around with things and it’s not looking up.

I’ve found that everything taken from the races sheet (trade agreements, tiles, planet cards) has become stuck.

When I load the original mod with the original save it works fine.

When I start a new game of the new module it works fine.

When I compare attributes of the two modules they are the same.

The cards all have 2 actions: send to player area + send to reference area (back to where it came from)

I tried sending them all back in the original then updating and they are still broken (albeit they are gone)

Now the tiles that make up the rest of the board come from a SETUP window and were placed on the main map. This is the same situation as the race tiles. Why they continue to work as intended (moveable, under other pieces, etc.) is beyond me.

These pieces weren’t cloned or parts of an infinite pile of something, they are unique single pieces. I could POTENTIALLY copy the all the pieces I need from the new module onto the map and those ones might work (and we would just use that hacked module for this game, then go back to the new module) either that or I need to re-create the state in 1.3 which is fine, we didn’t really have a lot going on (though I can’t do it ALL because some cards are secret, we would need to each of us draw them out manually)

I’m going to keep plugging away at it, but my list of possible fixes is dwindling.