Vassal Crashes when navigating to new Directory during Save As

Took me a long while to figure this out, but any time (of late) I do a Save As, and I need to change the directory, the Vassal crashes/ This isn’t with a specific mod (happened with Conquistadors and The US Civil War. I uninstalled Vassal and reinstalled, same issue. I do have a logfile, but uanble to attached it.

--------------- S U M M A R Y ------------

Command Line: -Xms512M -Xmx512M -Duser.home=C:\Users\Admin -Duser.dir=C:\Program Files\VASSAL-3.5.8 VASSAL.launch.Player --load – D:\VASSAL\The U.S Civil War\TheUSCivilWar_v1_06.vmod

Host: Intel(R) Core™ i9-10900X CPU @ 3.70GHz, 20 cores, 31G, Windows 10 , 64 bit Build 19041 (10.0.19041.1202)
Time: Sun Oct 3 11:07:26 2021 Mountain Daylight Time elapsed time: 30.809003 seconds (0d 0h 0m 30s)

--------------- T H R E A D ---------------

Current thread (0x0000026ba635c1a0): JavaThread “AWT-Windows” daemon [_thread_in_native, id=3932, stack(0x00000082f3200000,0x00000082f3300000)]

Stack: [0x00000082f3200000,0x00000082f3300000], sp=0x00000082f32fbaa0, free space=1006k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [awt.dll+0xa55ae]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j java.desktop@16
j java.desktop@16
j java.base@16
v ~StubRoutines::call_stub

siginfo: EXCEPTION_ACCESS_VIOLATION (0xc0000005), reading address 0x0000000000000038

--------------- S Y S T E M ---------------

Windows 10 , 64 bit Build 19041 (10.0.19041.1202)
OS uptime: 9 days 1:13 hours

CPU: total 20 (initial active 20) (10 cores per cpu, 2 threads per core) family 6 model 85 stepping 7 microcode 0x5002f01, cx8, cmov, fxsr, ht, mmx, 3dnowpref, sse, sse2, sse3, ssse3, sse4.1, sse4.2, popcnt, lzcnt, tsc, tscinvbit, avx, avx2, aes, erms, clmul, bmi1, bmi2, adx, avx512f, avx512dq, avx512cd, avx512bw, avx512vl, fma, vzeroupper, avx512_vnni, clflush, clflushopt, clwb

Memory: 4k page, system-wide physical 32445M (24060M free)
TotalPageFile size 37309M (AvailPageFile size 24305M)
current process WorkingSet (physical memory assigned to process): 253M, peak: 253M
current process commit charge (“private bytes”): 769M, peak: 771M

vm_info: OpenJDK 64-Bit Server VM (16+36) for windows-amd64 JRE (16+36), built on Mar 11 2021 10:56:33 by “” with MS VC++ 16.7 (VS2019)

That’s Java crashing, so it’s not our bug.

Do you suggest then perhaps updating Java. It may not be your bug, but it is happening with Vassal, so some guidance would be helpful.

Try a current build (search for VASSAL-3.6.0-SNAPSHOT-5b3a16c), as those are using Java 17 instead of Java 16.

Will do. Updating Java itself had no impact.

This is expected, because for quite awhile now VASSAL has come with its own self-contained bunch of necessary Java bits, and does not use any system-installed Java you might have.

It is actually worse. It crashes when trying to load a game.

Worked via double-click in Windows Quick Access, odd.

I know this isn’t VASSAL, we think, per say, but this still happens all the time for me. My Windows is up-to-date, and everything else is. The crashing during folder navigation makes it very hard to update modules, load extensions. Any thoughts? Am I the only one experiencing this?

Something about your machine is making the Java file dialog go off the rails.

  • Does it crash immediately on opening the Save As dialog?
  • If not, to what extent are you able to interact with the Save As dialog?
  • Does it crash when you browse to a particular directory?

Keep in mind that this kind of problem is extraordinarily difficult to troubleshoot remotely. Don’t be upset if we go through a lot of effort yet never solve the problem or even discover the cause.

Mostly it is changing directories when you need to load a new module, load a save game. I understand how hard it is. I am a software tester by trade, and I know how terrible a bug this is that I described and able to reproduce.

Be more specific. Is it changing to any directory? Are there directories you can change to without a crash?

I will try to maybe upload a video, but it happens mostly when manipulating directories (changing them it always happens). Also, happens when doing a Save As. It happened this morning when I was loading a new module and had to change directory for that.

I see in the java crash, that they have a link to submit a bug there, so I may there as well as this is making VASSAL close to unusable at times. I am starting a PBEM game, and I feel I might not be able to as Saving is a crap shoot.

It is clearly not interacting well with something on my PC and I just can’t suss it out.

Many years ago I helped someone having a file dialog problem where we determined that a bad registry key was the culprit. I don’t remember anymore if the symptoms were that the file dialog would hang or crash, but we fixed it by removing a bad registry key.

My current guess is that you have a bad registry key, because that’s a thing which could differ between your machine and machines which are working. (But it’s still a bug in Java if my hunch is correct, because a bad registry key ought not cause a crash.)

Do you get a file named something like hs_err_pidXXX.log when the crash happens? (Is the first thing you posted the contents of that? If so, is there any more in that file?)

Well, I could uninstall for sure, and then search the registry and wipe out of the VASSAL instances. That should be too painful. I will give that a go tonight.

I’m not saying it’s one of our registry keys; my memory is that it wasn’t in the previous case.

If you uninstall Vassal, there should be no keys left behind, but it’s worth checking. Let me know if you do find any.

I’m really reaching here, but could you take an inventory of other programs that are running (likely in the background) at the time you are using VASSAL and getting these crashes? Common culprits could include antivirus, anti-malware, system monitoring software, etc. It’s been a couple years but a user once had a really obscure problem related to screen-reading software–that pre-dated the “VASSAL comes with its own Java” thing, but it still might be worth checking out.

Sure. I think i disabled anti-virus at one time (it is just windows defender so I would suspect others would have that issue if it were that). I will not them, and maybe kill them one by one and see if I get the results. we like.

Two simple suggestions -

  1. Try disabling hyper threading and see if that has any effect.
  2. Reboot the machine into safe mode and see if the problem is still occurring.

Good Luck!

I THINK I may have solved it after doing many things, but it appears that uninstalling and then re-downloading 3.5.8 and reinstalling did it. I uninstalled a bunch of newer programs, but so far so good. I will keep you all updated.