Vassal Crashes when navigating to new Directory during Save As

Nope. Seems more infrequent though.

I notice in your initial post that you’re accessing a module on another drive (D:). What kind of device is this drive? If it’s an external or network drive, I’m wondering if you’re having connection issues and Java is choking on them…

It is a SSD drive, so not external, and it worked on this drive for a long while. I would expect it is not that, but it could be.

I still probably need to pursue uninstalling it fully. Despite going through the registry and searching, some still remains, because everytime I re-load it, it has all my modules installed. I am missing something somewhere.

Also need to try the threading.

Moving it all over to the C drive might need to be my next move.

That’s not in the registry. That’s from the config files stored in your user directory, in C:\Users\<username>\AppData\Roaming\VASSAL.

I figured so. Odd that when I searched, it didn’t pick that folder up. I am baffled that it has seemed to crash less last night in testing (at one time I thought it was related to double-clicking). I have another idea I may try out tonight, but this is odd.

More specifically, the D drive (I think) is a M2 SSD. This computer is very new. But as I said, this is a new development, so it must be something I installed I suspect, but running out of things to remove.

$HOME$\AppData is a hidden folder–I don’t remember offhand how Windows search works “out of the box,” perhaps something extra has to be done to have hidden folders included (if they aren’t by default).

I tend to unhide all that stuff, but maybe I didn’t or maybe Windows handles it differently than before.

Well, lordy be, it appears that 6.3.1 fixed my random crashing issue. :smiley: So far, no crashes doing saves and various activities–fingers crossed.

1 Like

3.5.8 and the 3.6.0 development build you tried have older versions of Java bundled with them than 3.6.1 does. Your experience suggests that the bug you were seeing is fixed in the newer version of Java.

And it crashed today. :frowning: I had just updated to 3.6.2, and I never saw a crash with 3.6.1. Doubt it was .2, but maybe? Sigh.

The crash is far less common now. Now, it seems most common when I have two different modules open. Not 100% but enough to see a pattern.

Gagh this crash. It is again worse with 3.6.4. What the heck is on my computer that causes this?

Was this ever attempted? Reviewing the posts it’s not clear if you ever established a pattern of this happening only when browsing the directory structure on the D: drive, or if it’s an equal opportunity crash afflicting both drives.

I did and it did not help. The issue SEEMs to be fully resolved with perhaps 3.6.6, but time will tell.

Not that anyone can do anything about it, but it is back. It is so odd. It seems the longer a new version is installed, the more likely it starts doing this. That makes no sense, but at the beginning of 3.6.6, it never crashed, but now it is back to crashing all the time when you try to load saved games and change directories or load modules when you change directories.