Version 3.6.1 - Can't get and Action Button trait

I just created an At-Start Stack in a Player Hand. This stack is intended to carry a button that players will use to draw a card.

Created a new piece, loaded the button image and this tried to add the Action Button trait but when I click the Add button, nothing happens.

I’ve replicated this in v3.6.0 and v3.6.1 and created issue #10883.

Affects attempts to add an Action Button to a prototype or direct to a piece on a deck or in a palette.

Affects both edits of module generated under v3.5.8 and newly created in v3.6.

An existing Action Button can be edited and copy/pasted (providing a workaround).

All other traits still add fine.

(thread title corrected for Vassal version).

I have fixed for 3.6.2, thanks. (I swear I fixed this before but it somehow didn’t make it into the code)

Meanwhile you can also drag-and-drop an Action Button into the window (in addition to the other workarounds mentioned)


Excellent. Let us know when there’s a build with this fix available. I’d use the workaround except that it’s the first Action Button I’ve tried to install in the mod so I have nothing to copy :grinning:

Other work around (that will work for you) is click on the words Action Button in the first list and drag that into the list of your traits. That will create a new one for you.

1 Like

The most recent master build will already have the fix: Builds of vassalengine/vassal

1 Like

The drag and drop worked.

Thanx! You guys are awesome.

1 Like

Actually, I dragged & dropped the Action Button into the trait list but it seems to be non-functioning. Here’s my logic. Done this a hundred time before so I don’t think missing anything.

It’s a Single Piece in an At-Start Stack

Action Button - Invoke Key Command - DrawClick
Box checked to use entire graphic

Trigger Action - Key Command - DrawClick
Perform These Commands - Click, GetCard

Play Sound - Key Command - Click

Global Key Command - Key Command - GetCard
Send Global Key Command of SendToHand to Specific Deck called Response
Get 1 Card

And I have the cards prototype set up to send a card to that Player Hand.

But it just doesn’t work. Can’t even get a click out of it. Barring a flaw in my logic somewhere, I’m going to download and install the latest build. I’ll let you know it that works.

If you have problems with the latest build, dropbox us up a copy of your module and tell us where to look for your action button and I’ll check it out.

Ok. I downloaded this build


Still can’t get the action button to work. Link to the mod below.

It’s easy to find as I was working on the Player Hand for the Player Side of Anchor. So you’ll see and Anchor [Player Hand] in the main tree. It only has one At-Start Stack with one piece. That’s where it’s at.

Okay I’ve found the “problem”. It will all work right for you if you just add a “Does Not Stack” to the piece.

It is possible that Action Buttons on stacking pieces placed via At-Start Stacks have never worked, ever. Or only worked after the piece moved once.

Even with your piece, when I was occasionally able to drag it somewhere and move it (had to aim right so it didn’t snap back), then I was able to get the click to work.

ANYWAY – we will consult internally on what to do about the bug you’ve found, but meanwhile for your purposes just add a Does Not Stack and everything will magically work!


1 Like

Ahhhh. Yeah, I usually put a DNS on a piece the very first thing but I was just testing something. Could be the reason I’ve never had it fail before.


Hi, this is similar to my problem too, my Action Buttons don’t seem to want to work. They are all in At-Start Stacks.

I’ve added DNS to one to test this workaround. Now when I click it I get a message that it is performing (rolling a die) but the result never makes it to the screen. The value of the die roll is supposed to be passed to another stack for display. I get this error:

“Bad Data in Module: Source: followProperty[diceValue]=1d10_result Error:Strategic Intelligence Roll [Layer - Dicelevel]. Numeric field contains a non-number. See the errorlog for more details.”

(not sure where the errorlog is)

Thanks so much for your help and patience.

Thanks, found the error log.

FWIW. :wink:

It sounds like some kind of syntax problem with your expression - if you’re having trouble finding it, link a copy of your module here (and tell me where to find your action button) and I’ll take a look.

Thanks so much!

(hope that works.)

The Action Buttons are At-Start Stacks in the Allied (and Japanese) Display Private Windows. There are several in each window, having the same issue with all (not surprisingly)

It made me “request access”, so just be sure to respond to that :slight_smile:

ok, I think i did what it wanted.

It looks like your Action Button traits are firing fine, but you’re having trouble actually rolling the dice.

It looks like you are sending a global hotkey of “Ctrl+R” thinking that that will roll the dice, but actually the hotkeys for your dice buttons are things like F8. So I imagine if you send the right hotkey to the dice buttons that then they will create results more correctly?