Action Button not firing

I have seen where clicks on a Action Button does not “fire”. It is never persistent, so always works after a few more clicks.
Is there something I can do to make it more of a sure fire thing?

I think what you’re mainly experiencing is the bug-thing in all versions of Vassal prior to 3.4 where Vassal interpreted mouse motion of even a single pixel as a “drag”. And so with the action buttons if you’re not “perfectly crisp” with your click it treats it as a drag select.

This should be fixed in 3.4 (you can try it out with the 3.4.0-beta and see if you agree).

In the meantime the only thing you can do is clip very “crisply” :slight_smile:

Many thanks.
I play a lot of ASL via VASL, so as soon as VASL is sanctioned as 3.4 compatible I am there!

Hi all! Has this bug been fixed? I’m still seeing it in 3.4.6.

Let me elaborate a bit.

VASSAL 3.4.6

Steps to reproduce
Press left mouse button on Action Button. Keep pressed and drag the mouse pointer along the Action Button area. Then release the mouse button.

Expected behavior
The Action Button should be fired.

Actual results
The mouse just draws selection rectangle and nothing happens.

Does this still occur in 3.4.9? If so, what module should I use to reproduce the problem?

Another question, if you can test it, does this bug manifest when using a trackpad to do the click ?

I have a lot of action buttons in the module that I am working on. I recently identified a similar sounding problem, when I started using a Mac with a mouse. I have since realised that my play-testers also experience click-issues with mouse actions. We are on a mix of Mac and PC platforms. One person is on Mac/Linux but I’d need to check if they have the same issue.

I found it is just action button left-clicks. The mouse otherwise works fine in Vassal (command tool buttons, right click etc) and the exact same Action Button click using a trackpad works fine.


Just re-tested my similar-seeming issue on MacBook 13", under v3.4.9 and it looks fixed. I will do some more testing. Did something that might have fixed this change from v3.4.8 ?

Thus spake marktb1961:

Just re-tested my similar-seeming issue on MacBook 13", under v3.4.9 and
it looks fixed. I will do some more testing. Did something that might
have fixed this change from v3.4.8 ?

Nothing I can think of.


Hoping its not some kind of placebo effect but my friend (on PC) also seemed not to have the problem anymore, otherwise I might have been thinking it had something to do with me upgrading MacOS. I do think its a real change - before I’d estimate 30-50% of mouse clicks were being ignored, creating a level of frustration that we didn’t get at all in the game I’ve just played. I am interested to hear from the OP to see if they still see the issue or not.

Please see attached test module. It has just one immobilized square piece with Action Button which toggles between red and green color.

Tested on VASSAL 3.4.6, 3.4.8 and 3.4.9: always the same bug - doesn’t work when press-drug-release.

My detailed environment:

OS Name: Microsoft Windows 10 Pro
OS Version: 10.0.19042 N/A Build 19042

java version “1.8.0_271”
Java™ SE Runtime Environment (build 1.8.0_271-b09)
Java HotSpot™ 64-Bit Server VM (build 25.271-b09, mixed mode)

Also tried on this Environment and got the same behavior:

CentOS Linux release 8.2.2004 (Core)
openjdk version “11.0.9” 2020-10-20 LTS
OpenJDK Runtime Environment 18.9 (build 11.0.9+11-LTS)
OpenJDK 64-Bit Server VM 18.9 (build 11.0.9+11-LTS, mixed mode, sharing)

Hi Nelud, I am not sure if your issue is the same as mine and whether mine is the same as the OP’s. However, just to say that I have found I was premature the other day - the “mouse click ignored on action button” issue that I have is still there on my iMac and on the various machines of people that I am play-testing my module with.

I will continue keeping an eye on this thread and will take my version of the issue back to my own thread.


I’ve tried this with a 3.4.11 development build and I’m not sure what I’m supposed to be seeing. The square toggles colors when I click it. Is there an earlier version where you see different behavior?

Wait, I’ve now seen further up the thread your description of what you were expecting to happen:

“Press left mouse button on Action Button. Keep pressed and drag the mouse pointer along the Action Button area. Then release the mouse button.”

The button should not activate in that situation, as that’s not a click.

I’m sorry uckelman, I’m really appreciate your great efforts to develop such an extremely useful software, but I think you are totally wrong at this point.

Please reread this thread from the very first post. You see? The actual bug is: sometimes Action Button doesn’t fire. Or you can think about it another way: Action Button fires only sometimes. And that is the very annoying bug, which is not resolved yet! It’s sad that you cannot admit it. Ok, let me explain in more detail.

So why could it happen? Let’s read the thread further. And… Surprise! It’s alredy mentioned there:

Please take a look at how toolbar buttons work. Or see ANY button in ANY window. It work the way I described. Everyone can press the button, drag a bit, and release - and it works! That’s the way the people expect it to work. So buttons work even if someone has hand tremor, or buggy mouse (for example, with jammed button that cause people to struggle pressing it and so it’s hard to avoid cursor shifting), or if the cursor trembles for some other reason. I have no such problems, but have ActionButtons work only from time to time.

So my test (press-drag-release) is not some artificial rare case. No! It’s just the way to reproduce the bug 100% of time.

Imagine a module that have a logic in a toolbar buttion. For example, it might prompt user to choose some option. Then I decided to make the module nicier, and replace the toolbar button with a checkbox on a MapWindow, which is made via ActionButton. After that user can come to me with the complaint: “Hey man! There was a button that works perfectly for me. Now I need to struggle pressing your &$#$%^&& checkbox!”

I beg your pardon for my excited writing. I never intended to offend you somehow. It seems the things that I believe are obvious turned out to be not so obvious! :slight_smile:

Buttons in UIs aren’t triggered by clicks. They’re triggered by press events followed by release events. Buttons in UIs are also not draggable normally. If you look at an interface where you can rearrange buttons—editing a toolbar in Firefox comes to mind—you’ll find that when the buttons are draggable, you cannot depress and release them.

What do you suggest we do in the case where a piece with an Action Button trait can be moved?

Is this behavior affected by the mouse drag threshold? I seem to recall the ability to modify the threshold was added in a recent version of VASSAL. I would think that increasing the drag threshold should solve this problem for most people (albeit making it a bit harder to actually initiate a drag action).

Thank you for replies! Yes you are right, the Firefox buttons can be dragged. Yes, they have some drag threshold.
But ActionButton doesn’t fire even if I drag the cursor by a single pixel. I’ve raised “Mouse Drag Threshold” to 100, but it still doesn’t work. By the way, how it is supposed to work? I haven’t found the description of this option in the User’s Guide.

I think if the “Mouse Drag Threshold” made it possible to drag a set distance when clicking, then it would be sufficient. But it would be better to have the possibility of using ActionButton on unmovable pieces even with zero threshold.

Okay, I’ve filed a bug report … i?id=13742 for Action Buttons not honoring the Mouse Drag Threshold.